Saturday, May 3, 2014

For Developers: Re-Up of Symbian Development tools

Sadly Nokia recently removed all Qt and Symbian Development tools from http://developer.nokia.com :(

But luckily I created a backup of the most intresting files and thanks to matthewkuhl, Nikitia and Jennifer we could find some missing parts and thanks to Eric and his MedaFire accout we could easily reupload:

  • All Qt 1.2.1 SDKs (Linux x64 and x32, Mac and Windows)
  • s60v3, s60v5, N97, S^3 and Belle SDKs 
  • Symbian^3 PDK v3.0.4 and 4.0a
  • Offline Developer Libraries of s60v3, s60v5, S^3, S^3 PDK and Belle
  • GCCE 4.6.3 + docs
  • RVCT 4.0 icnl. SP3 + 4.1 -  requires a license
  • Carbide C++ (3.2 and 2.7)
  • NokiaWebTools 1.2.0
  • Carbide UI 4.3 and a couple of plugins
  • Ruby
  • PyS60 (2.0.0, 1.9.7, 1.9.6)
  • Silverlight 
  • eBooks about Symbian, Qt, C++ and Assembler
  • Open source projects by CODeRUS and Kolay
  • A lot of useful modding tools


Here's the link: https://www.mediafire.com/folder/79jhy594xb3uk/Symbian_Development


If you want to support our Mediafire account:

Regards
Fabian (huellif)

29 comments:

  1. Very nice work, it's not possible with the back up of developers tools update the official nokia browser to support embedded flash videos and silverlight videos??

    ReplyDelete
    Replies
    1. We have the S^3 browser sources which are really outdated, this would require latest Belle FP2/Refresh sources.

      Delete
  2. Thanks so much thanks by the way did you have the asha plugins for carbide???

    ReplyDelete
    Replies
    1. I will try to find it and soon the collection will contain the s60v3 developer libs

      Delete
    2. Read here: http://developer.nokia.com/community/wiki/Archived:Carbide.ui_plug-in_for_Series_40_Developer_Platform_2.0_%28Full_Touch_UI%29

      Delete
  3. how to install carbide 4.3 in win 8?how to use plugins? give me tutorial.........

    ReplyDelete
    Replies
    1. What exactly is the problem?
      can't you run the installer or what doesn't work?
      And you have to unpack the plugins the the plugins subfolder of your Carbide.UI installation

      Delete
    2. when i install Carbide.UI 4.3 in win 8.1 only show the command prompt and then it will close with in 2seconds not running installation process why.

      Delete
    3. easay, becaeindows 8 sucks. try running as admin in compatibility modus

      Delete
  4. muchas gracias desde Bolivia por este gran aporte

    ReplyDelete
  5. Updated:
    - PyS60 v2
    - PyS60 v1.9.7
    - PyS60 v1.9.6
    - Symbian Ruby 1.9.2.0
    - s60v3 offline developers library

    ReplyDelete
  6. Can somebody help us to collect the development tools and docs of:
    - Flash Lite
    - Java ME
    - .NET

    Thanks in advance!

    ReplyDelete
    Replies
    1. .NET/Silverlight is solved

      Delete
    2. i have a lot of my file mirrors uploaded, if you want the links. i'll be updating as i have time but the folders are open shares so no new links will be necessary.

      Delete
    3. Sure, can you post them here or send me an email/PM?

      Delete
  7. - S^3 PDK 3.0.4 and 4.0a are uploading ...
    No will be no more need of the slow torrent downloads :)

    ReplyDelete
    Replies
    1. Ha ha, i am at 90% downloaded and was planning to do the same =o)

      Delete
    2. 98%; the first file of the PDK is up in my Drive now.
      Those are all of the Carbide.ui plugins for Symbian, by the way ;o)

      Delete
  8. hi! Fabian , plz help me , where I can find the simulator , PDK , Symbian SDK or QT SDK

    ReplyDelete
    Replies
    1. Hi
      click the Mediafire link and check all the folders, you will find what you want.
      There are many simulators (for each SDK and PDK), two PDKs, diffrent Symbian SDKs for diffrent OS versions and QtSDK builds for OSX, Linux and Windows

      Delete
  9. Hello Michael,


    thanks for your kind feedback, but that's the wrong blog post :P
    Nice to hear there still are some Delight users around these days.


    Regards

    ReplyDelete
  10. I have Symbian 9.2 SDK (S60 fp1) v1.0.1. Do you need it? If yes, where to download it?

    ReplyDelete
  11. Do you need Symbian 9.2 (S60v3 fp1) v1.0.1 SDK? If yes please guide where to download it.

    ReplyDelete
  12. That's nice Nikita :)

    You can upload it where you want (Dropbox, box.net, skydrive, a file hoster) and share the link, than I will mirror it to our Mediafire account and put your name to the credits.

    Thanks in advance!

    Regards

    ReplyDelete
  13. I've uploaded it here http://d-h.st/v8l
    Thanks for your job.

    ReplyDelete
  14. Thank you very much Nikita :)
    I will mirror it as soon as possbile.

    ReplyDelete